A fix has been implemented and we are monitoring the results.
Posted Aug 04, 2025 - 13:32 PDT
Update
We are continuing to work on a fix for the Driver Safety - Coaching and Driver Assignments issue impacting some clients. We apologize for any inconvenience and will provide further updates as soon as we have them.
Posted Aug 04, 2025 - 10:31 PDT
Identified
The issue with Driver Safety - Coaching and Driver Assignments has been identified and a fix is in process. Please note: this issue only impacts new driver creations added in the last 72 hours.
Posted Aug 04, 2025 - 08:12 PDT
Investigating
We are investigating reports of a possible service disruption affecting Driver Safety - Coaching and Driver Assignments for some clients. Specifically, users may experience issues in assigning drivers to safety events. We apologize for any inconvenience and will provide further updates as soon as we have them.
Posted Aug 04, 2025 - 06:30 PDT
This incident affected: Safety & Risk (Coaching, Library).