Lytx ELD - Degraded ELD Performance

Incident Report for Lytx Inc.

Resolved

This incident has been resolved.
Posted Sep 25, 2023 - 16:17 PDT

Identified

We’re currently investigating reports of a potential service degradation. Our services are currently not interrupted and we apologize for any inconvenience. We will post an update as soon as we learn more about the issue.
Posted Sep 25, 2023 - 13:25 PDT
This incident affected: Compliance (ELD).