Investigating - Driver Safety Dashboard & Event Library

Incident Report for Lytx Inc.

Resolved

This incident has been resolved.
Posted Mar 30, 2026 - 10:07 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 30, 2026 - 09:53 PDT

Investigating

We’re continuing to experience a service disruption with the Driver Safety Dashboard and the Event Library. Some clients may be observing errors when accessing the Dashboard and experiencing difficulties in the ability to view/play Safety Events. Our Engineering teams are working to identify the root cause and work towards a resolution.

We apologize for any inconvenience and will provide further updates as soon as we have them.
Posted Mar 30, 2026 - 08:32 PDT

Monitoring

A fix has been implemented, and we are monitoring the results. Please note that you may encounter some minor latency as our systems return to normal functionality.
Posted Mar 30, 2026 - 07:19 PDT

Investigating

We’re currently experiencing a service disruption with the Driver Safety Dashboard and the Event Library. Some clients may be observing errors when accessing the Dashboard and experiencing difficulties in the ability to view/play Safety Events. Our Engineering teams are working to identify the root cause and work towards a resolution.

We apologize for any inconvenience and will provide further updates as soon as we have them.
Posted Mar 30, 2026 - 05:56 PDT
This incident affected: Safety & Risk (Coaching, Library).