Investigating - Driver Safety Dashboard

Incident Report for Lytx Inc.

Resolved

This incident has been resolved.
Posted Jun 30, 2025 - 17:11 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 30, 2025 - 17:04 PDT

Identified

We’re currently experiencing a service disruption with Driver Safety Dashboard. Some clients may be observing errors when accessing the Dashboard. Our Engineering teams have identified the root cause and are working to implement a resolution.

We apologize for any inconvenience and will provide further updates as soon as we have them.
Posted Jun 30, 2025 - 16:12 PDT
This incident affected: Safety & Risk (Insights, Coaching, Library).