Investigating - Driver Safety

Incident Report for Lytx Inc.

Resolved

The issue with Driver Safety - Library Event playback has been resolved. No data was lost during this incident, however while the data recovers, some clients may experience a gap in Event footage between 8 PM PT 4/17/25 and 5 AM PT 4/18/25. We apologize for the experience.
Posted Apr 18, 2025 - 05:19 PDT

Update

We are continuing to work on a fix for this issue.
Posted Apr 18, 2025 - 04:15 PDT

Identified

The issue has been identified and a fix is being implemented.
Posted Apr 18, 2025 - 02:13 PDT

Investigating

We’re currently experiencing a service disruption with Driver Safety - Library where some clients are unable to view Events. Our Engineering teams are working to identify the root cause and implement a solution.

We apologize for any inconvenience and will provide further updates as soon as we have them.
Posted Apr 18, 2025 - 01:25 PDT
This incident affected: Safety & Risk (Library).