Driver Safety - Coaching

Incident Report for Lytx Inc.

Resolved

This incident has been resolved.
Posted May 22, 2025 - 07:20 PDT

Investigating

We’re currently experiencing a service disruption with Driver Safety - Coaching. Our Engineering teams are working to identify the root cause and implement a solution.

Some clients may be experiencing Coaching sessions not closing out after completing the coaching session/task.

We apologize for any inconvenience and will provide further updates as soon as we have them.
Posted May 22, 2025 - 06:21 PDT
This incident affected: Safety & Risk (Coaching).