We are continuing to investigate an issue affecting http://login.lytx.com that is causing intermittent access your Lytx Account. We apologize for the inconvenience and will provide further updates once additional information is available.
Posted Jul 13, 2026 - 05:06 PDT
Update
We are continuing to investigate an issue affecting http://login.lytx.com that is causing intermittent access your Lytx Account. We apologize for the inconvenience and will provide further updates once additional information is available.
Posted Jul 13, 2026 - 02:58 PDT
Investigating
We are currently investigating an issued affecting http://login.lytx.com. This incident may lead to an Access Denied error message, affecting your ability to access your Lytx Account. We apologize for any inconvenience caused and will provide further updates once additional information is available.
Posted Jul 13, 2026 - 01:54 PDT
This incident affected: Lytx Account Tools (Login Page (login.lytx.com), Lytx Installation Application) and API (Developer Portal).