Lytx Account Admin Performance

Incident Report for Lytx Inc.

Resolved

This incident has been resolved.
Posted Jan 27, 2026 - 07:37 PST

Investigating

We’re currently investigating reports of a potential service disruption impacting Driver Safety – Admin for some clients. Affected users may notice slower performance when accessing or loading the Admin page within Lytx Account. We apologize for the inconvenience and will share additional updates as soon as they become available.
Posted Jan 27, 2026 - 07:26 PST
This incident affected: Lytx Account Tools (Admin).