Driver Safety - Event Download - Major Outage

Incident Report for Lytx Inc.

Resolved

This incident has been resolved.
Posted Mar 21, 2025 - 11:32 PDT

Update

We are continuing to work on a fix for this issue.
Posted Mar 21, 2025 - 11:15 PDT

Identified

We are currently looking into reports of a potential service disruption impacting Driver Safety - Event Download. Some clients may experience an issue where the download button is missing while viewing Events.

We sincerely apologize for any inconvenience this may cause and will share further updates as soon as they become available.
Posted Mar 21, 2025 - 09:24 PDT
This incident affected: Safety & Risk (Library).