Login Page - Service Outage
Incident Report for Lytx Inc.
Resolved
This incident has been resolved.
Posted Apr 05, 2024 - 12:35 PDT
Investigating
We’re currently investigating a service interruption impacting login.lytx.com. This issue will impact your ability to log into your Lytx Account. We apologize for any inconvenience and will post another update as soon as we learn more.
Posted Apr 05, 2024 - 12:27 PDT
This incident affected: Lytx Account Tools (Login Page (login.lytx.com)).