Earlier today, some clients may have experienced issues with geofence creation and alerting within Fleet Tracking. A fix has been implemented to address the problem.
Please be aware that there may be a brief delay in data processing over the next few hours. Additionally, there was a gap in geofence data between 7:20 AM and 8:20 AM PST, which may affect visibility or alerts during that time period. No data was lost, and all Geofence records remain intact.
We appreciate your understanding and are committed to ensuring continued reliability of the service.
Posted Nov 10, 2025 - 09:42 PST
Monitoring
Some clients may have experienced issues with geofence creation and alerting functionality earlier today. A fix has been implemented, and we are actively monitoring system performance to ensure stability. Please note that there may be a brief delay in data processing over the next few hours. A gap in geofence data occurred between 7:20 AM and 8:20 AM PST, which may affect visibility or alerts during that time window.
Posted Nov 10, 2025 - 08:23 PST
Investigating
We’re currently experiencing a service disruption with Fleet Tracking - Geofences. Our Engineering teams are working to identify the root cause and implement a solution.
Some clients may be experiencing issues with Geofence creations, and alerts at this time.
We apologize for any inconvenience and will provide further updates as soon as we have them.
Posted Nov 10, 2025 - 07:51 PST
This incident affected: Fleet Tracking (GeoFence).